Follow

GIMP 

Instead of trying to salvage a project that's so venomous to "outsiders" that it's starved for contributors and now lagging 2 major versions/15 years behind its own GUI toolkit, let's fix Krita so more people can use that. There's plenty to be done there and the effort will actually be appreciated.

· Web · 9 · 11 · 31

re: GIMP 

@flussence Krita has a completely different purpose than GIMP. If GIMPs community is dying, a fork should rejuvinate it.

re: GIMP 

@flussence as i said, the software is aptly described honestly. it's very unstable and i haven't bothered using it in years because Krita is better in every way.

re: GIMP 

@kaniini Krita is better in a lot of ways, but honestly gimp 2.8 felt more stable. They've ruined that now, mind you

re: GIMP 

@flussence @kaniini Heck, azpainter which is probably maintained by one person is more stable than GIMP in my experience. (2.10 is broken for me and I don't even care)

re: GIMP 

@a_breakin_glass @kaniini GIMP should be ported to Qt honestly, everything else GTK 2 already has

GIMP 

@flussence
I love Krita and think it's way better regardless, but initially switched to it primarily because of the name thing

GIMP 

@flussence @lanodan i've often been told that krita and gimp have completely different usecases - is this not the case? May have been false advertising or the situation has changed

re: GIMP 

@sroracle @flussence GIMP is very focused on manipulating images, krita is more on drawing.

But in the end you can do most basic image manipulation in krita and I guess if you need more there is stuff like Darktable.

GIMP 

@flussence krita is super nice software but isn't it's use case different than GIMP?

GIMP 

@flussence Krita for Mac appears to be particularly underresourced, based on the limited range of macOS versions it supports. I would absolutely love it if I could use newer versions on Yosemite but I can sympathise with their decision not to support it.
(Krita people, let me know if I'm barking up the wrong tree here)

Krita MacOS support (was: GIMP) 

@Reinderdijkhuis @flussence Sadly, the mac os problem is caused by our framework, Qt not supporting versions older than 10.12: doc.qt.io/qt-5/macos.html

I mean, I guess a build could be attempted with an older version of qt, but an interested dev who likes MacOS would need to come say hi in the #krita irc on freenode if they want more info of what that would entail...

krita is better than the other thing anyway 

@flussence been using krita this whole time but i'm not a professional graphics person at all so i always felt unqualified to promote it instead of corporateshoop, glad someone else is saying this

Sign in to participate in the conversation
nulled.red

nulled.red is an any-topic moderated Mastodon instance made by me, Ami. Hosted in Roubaix, France.